[OSM-dev] Database Schema

Tom Hughes tom at compton.nu
Thu Oct 9 13:18:47 BST 2008


Brett Henderson wrote:

> I haven't had much luck either.  Does anybody have any suggestions on 
> where I've gone wrong below.
> 
> I installed the following packages.
> 
> yum install ruby ruby-devel ruby-irb ruby-libs ruby-rdoc ruby-ri rubygems ruby-sqlite3
> yum install ruby-mysql ruby-postgres ruby-clearsilver ruby-racc subversion-ruby ruby-docs
> yum install ruby-activesupport ruby-activerecord
> yum install rubygem-rails
> 
> The rubygem-rails package is version 2.1.1.  This differs from both the version specified on the fedora specific link above (version 1.2.3) and the version on the rails port page (version 2.0.2).  Perhaps this is the problem.
> 
> When I run:
> rake db:migrate
> 
> I get the error:
> Missing the Rails 2.0.2 gem. Please `gem install -v=2.0.2 rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.

Do what it says and install 2.0.2 as 2.1.x does not work with our code 
at the moment.

Tom

-- 
Tom Hughes (tom at compton.nu)
http://www.compton.nu/




More information about the dev mailing list