[OSM-dev] Move to rails 2.1.1 for api 0.6?

Tom Hughes tom at compton.nu
Thu Oct 9 14:53:13 BST 2008


Shaun McDonald wrote:

> Would it be safe to assume that for api 0.6 we can move to rails 2.1.1?

Well not until somebody has investigated the problems and found out what 
needs to be done to make it work. It's been a while since I worked on it 
so I can't remember now what the problems were.

> If so, I'll work on any problems that might arise while working on the 
> rest of api 0.6.

My memory is that it basically didn't want to work when some of the 
tables didn't have primary keys, which is why I want to make sure 
everything has a primary key in 0.6 then I was planning to look at 
moving to 2.1 again afterwards.

There is no need to do the two at the same time really.

Tom

-- 
Tom Hughes (tom at compton.nu)
http://www.compton.nu/




More information about the dev mailing list