[OSM-dev] Problem with Linux Install on "rake db:migrate" command

Tom Hughes tom at compton.nu
Mon Jun 1 23:57:38 BST 2009


Andy Allan wrote:

>> I have pasted my error below.  I am not sure what is causing the problem.
> 
>> /usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.2/lib/tasks/misc.rake:4:in
>> `block in <top (required)>'
> 
> Unless anyone else knows better than me, I think you've got the wrong
> version of rails installed. The documentation requires 2.2.2, and you
> have 2.3.2 - and a lot of the advanced stuff in OSM is very
> version-specific (plugins etc).

We specifically require 2.2.2 though, so unless the source has been 
hacked it shouldn't be loading 2.3.2 at all.

Tom

-- 
Tom Hughes (tom at compton.nu)
http://www.compton.nu/




More information about the dev mailing list