[OSM-dev] Problems with Planet-Excerpt Import into apidb

Holger Schöner numenor at ancalime.de
Thu May 21 19:29:23 BST 2009


Hi Brett,

> > When applying the db schema in two steps, I got a deadlock again, but
> > the import still seemed to work okay (osmosis terminated without error,
> > and nodes, current_nodes, ways, current_ways, relations,
> > current_relations were all filled with the same amount of rows as
> > before):
>
> Are you creating the indexes while osmosis is still running?  That would
> probably explain the deadlock.

Yes, I did, as I did not know of a way of splitting the actions of osmosis 
into more than one step (until you pointed out the populateCurrentTables 
option).

> Can you add the populateCurrentTables=no option to the --write-apidb
> task?  That will cause osmosis to skip the population of current
> tables.  Once osmosis has completed loading the history tables it will
> stop processing.  You can then run part two of the script without
> osmosis interfering.  Then you can populate the current tables manually
> yourself using something like "INSERT INTO current_nodes SELECT id,
> timestamp ...... FROM nodes".

Okay, now the import of Europe (still the same data of about two weeks ago) 
worked at least until before copying the data into the current tables. 
Because this copying took forever again, I am now going to try it without 
first running the second part of the setup scripts (creation of keys and 
indexes).

Thanks anyway, your hints have already brought me much further than I was 
before! My usual way of simply trying out everything is a little cumbersome 
here with these amounts of data ...

> Can you please post to the dev list instead of replying privately?  It
> means others can follow the conversation or perhaps even make
> suggestions.

I noticed after sending ;-)
-- 
Holger Schoener		numenor at ancalime.de





More information about the dev mailing list