[OSM-dev] Our beloved XML format doesn't parse; planet 11-11

M∡rtin Koppenhoefer dieterdreist at gmail.com
Wed Nov 17 18:04:00 GMT 2010


2010/11/17 Frederik Ramm <frederik at remote.org>:
>> https://bugs.launchpad.net/ubuntu/+source/bzip2/+bug/621130
>
> I could reproduce the bug here but only when piping uncompressed stuff
> through bzcat -f, which is a rather stupid thing to do anyway. Whenever I
> piped compressed stuff into it, it worked as expected.


I "discovered" this bug when I tried to import (compressed) srtm-data
I had converted with srtm2osm into my pgdb with osm2pgsql (I got the
error "file is empty" because the first line wasn't uncompressed
correctly). I "resolved" by decompressing and recompressing it with
gzip, so I am quite sure the osm-file was OK (file, more and tail also
"confirmed" this).

I could reproduce this bug also by simply compressing a whatever
textfile of 2-3 lines and then reading it with bzcat (the first line
got awful).

cheers,
Martin



More information about the dev mailing list