[OSM-dev] rails_port problem

Kirill Bestoujev bestoujev at gmail.com
Wed May 4 15:27:28 BST 2011


Tom,

sorry for being hard, I did not intend to harm anyone.

If the error is harmless then why this error causes the api to fail on 
my machine? This is the only error I get in rails log.

The info on my setup:

Ubuntu 11.04_64 (tried 10.04, OpenSuse 11.4) + apache 2 + passenger.

All the web part works fine - I can login, edit the map with potlatch, 
post to the diary. But josm does not work - it downloads data, it 
creates a new changeset, but fails to upload anything.

What other details are required?

Kirill


On 04.05.2011 18:04, Tom Hughes wrote:
> On 04/05/11 14:57, Kirill Bestoujev wrote:
>
>> Found a strange thing:
>>
>> http://cruise.openstreetmap.org/builds/osm-rails/3700b53/test.log
>> contains MANY
>>
>> "ERROROAuth::Signature::UnknownSignatureMethod" errors. Same as I get, but in many place. Why is osm server working well and mine does not?
>>
>> And why nobody cares???
> Why do you think that nobody cares?
>
> The question is not whether we care, but whether we have any ideas that
> might help you. I for one don't, which is why I haven't answered.
>
> The problems you are seeing are not ones I recognise, so there isn't
> much advice I can offer - as the person with access to the machine you
> are the person best placed to diagnose the problem.
>
> On top of which you haven't even told us what your setup is yet so it's
> hard to know what to say... What web server are you using, and how are
> you connecting it to rails?
>
> As to that OAuth::Signature::UnknownSignatureMethod message, just ignore
> it - it is completely harmless.
>
> Tom
>




More information about the dev mailing list