[OSM-dev] osmium (osmjs) compile problem

Frederik Ramm frederik at remote.org
Mon Oct 17 08:24:40 BST 2011


Hi,

On 10/17/2011 04:12 AM, Martijn van Exel wrote:
> I'm compiling osmium on Ubuntu 10.04.3 LTS. The first problem occurs
> when I try to compile the OSM PBF library. It does not work via the
> debuild route, which gives me:
>
> fileformat.pb.h:16:2: error: #error This file was generated by an older
> version of protoc which is
> fileformat.pb.h:17:2: error: #error incompatible with your Protocol
> Buffer headers. Please
> fileformat.pb.h:18:2: error: #error regenerate this file with a newer
> version of protoc.
>
> I can make / make install and that seems to go OK.

I solved this by backporting a more recent version of protobuf. Debian 
packages for lucid are here: 
http://www.remote.org/frederik/tmp/protobuf-23-lucid.zip

> On to Osmium where I run into trouble trying to compile osmjs:

Sadly this seems to be more complicated; lucid's standard V8 is too old 
and backporting a newer version requires a ton of dependencies. I 
compiled v8 from source and modified the -L and -I flags in the osmjs 
Makefile to point to my local version.

Bye
Frederik



More information about the dev mailing list