[OSM-dev] osmium (osmjs) compile problem

Jochen Topf jochen at remote.org
Mon Oct 17 08:39:30 BST 2011


On Sun, Oct 16, 2011 at 08:12:05PM -0600, Martijn van Exel wrote:
> I'm compiling osmium on Ubuntu 10.04.3 LTS. The first problem occurs when I
> try to compile the OSM PBF library. It does not work via the debuild route,
> which gives me:
> 
> fileformat.pb.h:16:2: error: #error This file was generated by an older
> version of protoc which is
> fileformat.pb.h:17:2: error: #error incompatible with your Protocol Buffer
> headers. Please
> fileformat.pb.h:18:2: error: #error regenerate this file with a newer
> version of protoc.

Ubuntu versions before 10.10 come with a version of the Google Protobuf stuff
thats too old. You have to either upgrade your Ubuntu, backport a newer
protobuf package or compile and install it from sources yourself.

> I can make / make install and that seems to go OK.
> 
> On to Osmium where I run into trouble trying to compile osmjs:
> 
> ../include/osmium/osm/tag_list.hpp: In member function
> âv8::Handle<v8::Array> Osmium::OSM::TagList::js_enumerate_tag_keys() constâ:
> ../include/osmium/osm/tag_list.hpp:138: error: no matching function for call
> to âv8::Array::Set(int, v8::Local<v8::String>)â
> /usr/include/v8.h:1145: note: candidates are: bool
> v8::Object::Set(v8::Handle<v8::Value>, v8::Handle<v8::Value>,
> v8::PropertyAttribute)
> 
> and many similar messages. Do I have an incompatible version of the V8
> library or what is the matter here?

Again, Ubuntu before 10.10 comes with a v8 lib thats too old.

Maybe Frederik can help a bit more. He builds the osmium/osmjs on Geofabrik
machines using 10.04 for me. :-)

Jochen
-- 
Jochen Topf  jochen at remote.org  http://www.remote.org/jochen/  +49-721-388298




More information about the dev mailing list