[OSM-dev] osm.xml for Mapnik-v2.2.0

Tom Hughes tom at compton.nu
Thu Jun 20 19:56:50 UTC 2013


On 20/06/13 20:31, Vince Berubey wrote:

>   * I know that osm.xml must be changed for the new version of Mapnik.
>     But even with the latest version of Mapnik I got there:
>     https://github.com/openstreetmap/mapnik-stylesheets, I still get the
>     same error than with the osm.xml for 0.7.1

That's a git mirror of the svn stylesheets I think, which is what we're 
currently running, but we aren't using 2.2 so it's not surprising that 
there may be issues.

You will be better off using the new carto based stylesheet, which will 
be going live soon, and which is definitely working with 2.2. You can 
find it here:

https://github.com/gravitystorm/openstreetmap-carto

Tom

-- 
Tom Hughes (tom at compton.nu)
http://compton.nu/



More information about the dev mailing list