[OSM-dev] osm.xml for Mapnik-v2.2.0

Vince Berubey screams_3 at hotmail.com
Thu Jun 20 19:31:48 UTC 2013


Hi,I use Windows 7. I had previously "mapnik-0.7.1" and just installed "mapnik-v2.2.0".
When I run "generate_xml.py osm.xml ..... ....", I get this error"RuntimeError: Must have 'face-name' set in FontSet 'book-fonts' in Font at line 9 of 'osm.xml'
I know that osm.xml must be changed for the new version of Mapnik. But even with the latest version of Mapnik I got there: https://github.com/openstreetmap/mapnik-stylesheets, I still get the same error than with the osm.xml for 0.7.1
I tried to write different things at line 9, but always get the same error. 
<?xml version="1.0" encoding="utf-8"?><!DOCTYPE Map [<!ENTITY % entities SYSTEM "inc/entities.xml.inc">%entities;]><Map background-color="#b5d0d0" srs="&srs900913;" minimum-version="2.0.0">  &fontset-settings;<Style name="turning_circle-casing">    <Rule>              <------------------Line 9

Best regards. 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20130620/660b7f1b/attachment.html>


More information about the dev mailing list