[OSM-dev] mod_tile stable version ?

Bernard Fouché bernard.fouche at kuantic.com
Tue Mar 26 15:49:26 UTC 2013


Le 26/03/2013 13:19, Sven Geggus a écrit :
> Bernard Fouché <bernard.fouche at kuantic.com> wrote:
>
>> - but I have crashes with renderd with what's currently available on the
>> SVN repo
> Frustration about renderd was the main reason why tirex was born a few years
> ago.
>
> So you will probably give it a try instead of renderd.
>
> https://trac.openstreetmap.org/browser/applications/utils/tirex
>
> Regards
>
> Sven
>
Speaking of frustration:

- I downloaded Tirex and failed to compile it because some include file 
wasn't provided in the mapnik F18 RPM
- I tried to recompile mapnik and failed because SConstruct wasn't able 
to find boost thread lib while the package is installed
- I looked at the missing include file in Tirex code 
(mapnik/expression.hpp included by backend-mapnik/metafilehandler.cc). I 
discovered that I can compile without including this file.
- Then I ran into `mapnik-config --dep-libs lists` that returns 
'-l[agg]' which breaks ld. I added a call to sed(1) to remove this from 
mapnik-config output .

Tirex compilation completed, now I'm battling to understand where to fix 
a mysterious "renderer internal error"  generated by 
tirex-backend-manager: I have mod_tile talking to tirex-master, the 
back-end manager sees the requests and then takes some time before 
failing with this message for each tile to generate.

     Bernard



More information about the dev mailing list