[OSM-dev] osm2pgsql 0.90.1 release

Sebastiaan Couwenberg sebastic at xs4all.nl
Mon Jul 18 13:07:27 UTC 2016


On 07/18/2016 02:24 PM, Paul Norman wrote:
> On 7/18/2016 4:32 AM, Komяpa wrote:
>> Is it available for Ubuntu Xenial?
> 
> It should compile fine, but Xenial has osm2pgsql 0.88.1 by default. I
> haven't backported all the changes to the 0.88.x branch, but I could.
> 
> The chances of Ubuntu getting the bug fixes is close to zero. I asked
> for a backport from Xenial to Trusty of something and got absolutely no
> response.

Important for context is that "something" was mapnik (from 2.2 to 3.0),
which is non-trivial due to breaking its reverse dependencies.

Both mapnik and osm2pgsql are in the universe component of Ubuntu, this
means that the packages are not maintained by Canonical employees and
the burden of maintaining those packages in Ubuntu is on the community.

Unfortunately the Ubuntu community lacks the number of developers to
maintain all those packages properly. Even Debian from where the Ubuntu
packages originate doesn't have enough developers to maintain all
20.000+ packages properly, but fortunately the situation in Debian is
not as problematic as in Ubuntu.

I spend all my spare time on maintaining the many GIS & OSM packages in
Debian keeping them in good shape, I cannot do the same for Ubuntu
unless maintaining the packages for Ubuntu becomes my day job.

The openstreetmap PPA on Launchpad could provide backports of OSM
packages for Ubuntu independently of the main Ubuntu archive, but has
the same problem as Ubuntu itself: it needs people to maintain those
packages for Ubuntu.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1



More information about the dev mailing list