[OSM-dev] OSM customization problems

Kojo rbsnkjmr at gmail.com
Fri Dec 7 17:45:01 UTC 2018


Jochen, Yves,
thanks for your attention.

When I stop rendered:

root at abcdef:/# ps -ef | grep renderd
root      40901  38529  0 15:24 pts/0    00:00:00 grep --color=auto renderd


And I request HTTP to clean a tile, it still answer:
"Tile submitted for rendering"

And when I ask for tile´s status:

Tile is clean. Last rendered at Thu Dec 06 19:37:30 2018. Last
accessed at Fri Dec 07 12:56:14 2018. Stored in
file:///var/lib/mod_tile/default/14/0/33/223/20/0.meta
(Dates might not be accurate. Rendering time might be reset to an old
date for tile expiry. Access times might not be updated on all file
systems)


I thought that renderd was in charge to answer for Apache ModTiles,
but I stoped renderd, restarted Apache but dirty/status stills answer.
And still nothing changes to applying style.

Andy, I am reading lots of documents. I will check those too.

Thank you,
Koji






> - renderd.conf XML property, points to a style file. I change this file
> but
> > the changes I made doesn´t show on tiles, even if I reload data to
> > database, and even if I mark the tile as "dirty" to force re-render. This
> > is the reason for the first question, that I can not even understand when
> > the style is applied, during import, or during render.
>
> Not sure but you might have to restart renderd and/or apache when
> changing the renderd config.





Em sex, 7 de dez de 2018 às 14:03, Jochen Topf <jochen at remote.org> escreveu:

> On Fri, Dec 07, 2018 at 01:36:32PM -0200, Kojo wrote:
> > Here I have some questions:
> > - I am using mapnik to style the maps, but it is not clear for me that
> the
> > style is applied  while importing data from osm to database (and stored
> > inside db data), or when the tile is rendered.
>
> Styles are applied when rendering *not* when importing.
>
> > - renderd.conf XML property, points to a style file. I change this file
> but
> > the changes I made doesn´t show on tiles, even if I reload data to
> > database, and even if I mark the tile as "dirty" to force re-render. This
> > is the reason for the first question, that I can not even understand when
> > the style is applied, during import, or during render.
>
> Not sure but you might have to restart renderd and/or apache when
> changing the renderd config.
>
> > - I tryed to check the png data direct on disk, but I couldn´t find it
>
> Tiles are stored as "meta-tiles" on disk, one meta-tile contains 8x8
> tiles. This might have thrown your calculations off.
>
> Jochen
> --
> Jochen Topf  jochen at remote.org  https://www.jochentopf.com/
> +49-351-31778688
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20181207/e73080f4/attachment-0001.html>


More information about the dev mailing list