[Imports] corrupt planet osm files

Zolt Egete xphreakster at gmail.com
Thu Jun 9 15:05:58 BST 2011


I have been trying to setup a separate GIS server using the following 
- geoserver
- postgres + postgis
- openstreetmap data

There is only one problem, I cannot work with the planet OSM file 
archive I download from the servers.
I have tried with the newest one and also have tried older archives as 
well, and all the time I get an error about a corrupt archive.

For unpacking I am using the bunzip2 command on my centOS server.

The source from where I have downloaded the new file is 
This archive was reported to be corrupted when an attempt was made to 
unpack it

Also I have tried with different files from 
http://ftp.heanet.ie/mirrors/openstreetmap.org/ which also seamed to be 
To be sure I have tried to unpack them both on the Linux box and also on 
Windows (using winrar) but I got the same results.

The files which I was able to unpack where from 
http://download.geofabrik.de/osm/ but those are split up data files and 
I would like to have a complete map of the world in one file.

Can you please give me a hint to know how to proceed ?

More information about the Imports mailing list