[OSM-newbies] Zoom level 12 MIA

James Ewen ve6srv at gmail.com
Fri Sep 16 05:03:53 BST 2011


On Thu, Sep 15, 2011 at 9:14 PM, James Ewen <ve6srv at gmail.com> wrote:

> Tiles on zoom level 12 of Mapnik maps have been MIA for a month now...

Looks like I figured out how to get them back into the rendering
queue. According to the way it's supposed to work, just looking at the
tiles should put them into the rendering queue if they are older than
1 week. For these tiles I have had to determine the tile number based
on nearby tile desigantions. Putting /status on the URL shows that the
last time the tiles were rendered was July 16. Manually marking them
as /dirty forced a render for that tile and ones nearby. This seems to
have kicked them back into existence again.

I've marked a number of tiles as /dirty. Hopefully this will "infect"
the rest of the tiles in the area, and the "infection" will spread,
making all the missing tiles rerender.

I'm thinking somehow a long strip of tiles at zoom level 12 got
deleted. When the map tile is requested, there's no associated file,
and thus there's no request to rerender the non existent tile.
Manually forcing it into dirty status causes a manual render, putting
the tile back onto the server, which should correct the issue.

The only problem I see is I'm not going to manually work my way from
Athabasca,  Alberta to Salt Lake City, Utah manually setting /dirty
status every few tiles to ensure the area gets rendered again.

Is there any way to set /dirty status on all tiles in a defined area?

-- 
James
VE6SRV



More information about the newbies mailing list