[OSRM-talk] Use osrm-routed as windows service

Kostadin Moraliev moraliev at gmail.com
Thu Sep 24 14:44:23 UTC 2015


Hello, I want to use osrm-routed.exe as Windows service.
1. Is there solution or I have to write my own code?

2. If there is no solution I'm going to write service for windows, but have
some problems building
Project-OSRM in Debug mode. In Release is OK.
For build I'm using Visual Studio 2015. All required tools are installed.
Source is from https://github.com/DennisOSRM/Project-OSRM
and for build use: build-local.bat in Project-OSRM root folder, but with
Debug flag.
=================================================================
Here is output from console:

CMake Error: The following variables are used in this project, but they are
set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake
files:
TBB_LIBRARY_DEBUG (ADVANCED)
    linked by target "osrm-extract" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "rtree-bench" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-routed" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "datastructure-tests" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "algorithm-tests" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-prepare" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-datastore" in directory
D:/osm/projects/debug-Project-OSRM
TBB_MALLOC_LIBRARY_DEBUG (ADVANCED)
    linked by target "osrm-extract" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "rtree-bench" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-routed" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "datastructure-tests" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "algorithm-tests" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-prepare" in directory
D:/osm/projects/debug-Project-OSRM
    linked by target "osrm-datastore" in directory
D:/osm/projects/debug-Project-OSRM

-- Configuring incomplete, errors occurred!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20150924/72282eb8/attachment.html>


More information about the OSRM-talk mailing list