[OSRM-talk] Use osrm-routed as windows service

Daniel Hofmann hofmann at mapbox.com
Thu Sep 24 16:28:13 UTC 2015


It seems like you are running into the cmake file for finding the Intel
Threading Building Blocks (TBB) library not being able to locate the debug
libraries:
https://github.com/Project-OSRM/osrm-backend/blob/master/cmake/FindTBB.cmake#L239-L242

Can you make sure that you have the TBB debug libraries available.

On Thu, Sep 24, 2015 at 4:44 PM, Kostadin Moraliev <moraliev at gmail.com>
wrote:

> Hello, I want to use osrm-routed.exe as Windows service.
> 1. Is there solution or I have to write my own code?
>
> 2. If there is no solution I'm going to write service for windows, but
> have some problems building
> Project-OSRM in Debug mode. In Release is OK.
> For build I'm using Visual Studio 2015. All required tools are installed.
> Source is from https://github.com/DennisOSRM/Project-OSRM
> and for build use: build-local.bat in Project-OSRM root folder, but with
> Debug flag.
> =================================================================
> Here is output from console:
>
> CMake Error: The following variables are used in this project, but they
> are set to NOTFOUND.
> Please set them or make sure they are set and tested correctly in the
> CMake files:
> TBB_LIBRARY_DEBUG (ADVANCED)
>     linked by target "osrm-extract" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "rtree-bench" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-routed" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "datastructure-tests" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "algorithm-tests" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-prepare" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-datastore" in directory
> D:/osm/projects/debug-Project-OSRM
> TBB_MALLOC_LIBRARY_DEBUG (ADVANCED)
>     linked by target "osrm-extract" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "rtree-bench" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-routed" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "datastructure-tests" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "algorithm-tests" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-prepare" in directory
> D:/osm/projects/debug-Project-OSRM
>     linked by target "osrm-datastore" in directory
> D:/osm/projects/debug-Project-OSRM
>
> -- Configuring incomplete, errors occurred!
>
>
>
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20150924/36de1c0d/attachment.html>


More information about the OSRM-talk mailing list