[OSRM-talk] One request, 2 answers

Didier Doumerc doumerc.d at adimep.com
Mon Mar 21 12:41:57 UTC 2016


Of course. Well, I needed another pair of eyes to see this evidence.

Otherwise, did you modify the default parameters in the car.lua file ? Some speeds seem to be low.

Thank you +++

Didier

Le lun.21/03/16 à 12:37, Julien Coupey a écrit :

> Hi Didier,
> 
> I'm getting the same kind of result of about 503 km on a custom server set-up with *only* the french road network. But if you look closely at the 379 km route you get from the demo server, you'll see it goes a long way through Switzerland.
> 
> My guess would be the second option (data mismatch), with the additional bias of a missing country! ;-)
> 
> Best,
> Julien
> 
> Le 21/03/2016 11:59, Daniel Hofmann a écrit :
>> There are two problems I can see:
>> 
>> 1/ the demo server runs from the develop branch, and you are probably
>> running osrm-backend's latest stable release. It certainly could be that
>> we fixed a few issues in develop that you don't yet have locally.
>> 
>> 2/ the demo server re-runs the toolchain on a fresh planet on a daily
>> basis, and you're local extract may be outdated (or even a few hour newer).
>> 
>> As you can see there's both the possibility for 1/ code mismatch and 2/
>> data mismatch between the demo server and your local setup.
>> 
>> Cheers,
>> Daniel J H
>> 
>> On Mon, Mar 21, 2016 at 11:30 AM, Didier Doumerc <doumerc.d at adimep.com
>> <mailto:doumerc.d at adimep.com>> wrote:
>> 
>>    Hi,
>> 
>>    Here is my first message on this mailinglist.
>> 
>>    Some time, I get very different distances, depending of the server
>>    to witch I send the request.
>> 
>>    Example : 379 Km vs 503 Km. The right one is 379 km.
>> 
>>    router.project-osrm.org/viaroute?loc=48.407126,7.449348&loc=46.117948,6.359105&instructions=false&geometry=false
>>    <http://router.project-osrm.org/viaroute?loc=48.407126,7.449348&loc=46.117948,6.359105&instructions=false&geometry=false>
>> 
>>    Answer : [...]
>>    total_distance":379125,"total_time":14284,"end_point":"Place du
>>    Village","start_point":"Rue Taufflieb (D 35)"},[...]
>> 
>> 
>>    When I ask my own server :
>> 
>>    10.168.221.253:5000/viaroute?loc=48.407126,7.449348&loc=46.117948,6.359105&instructions=false&geometry=false
>>    <http://10.168.221.253:5000/viaroute?loc=48.407126,7.449348&loc=46.117948,6.359105&instructions=false&geometry=false>
>> 
>>    Answer : [...]end_point":"Place du Village","start_point":"Rue
>>    Taufflieb (D 35)","total_time":17081,"total_distance":503559}[...]
>> 
>> 
>>    Can someone tell me how to fix this ?
>> 
>>    Thanks
>> 
>>    Didier
>> 
>>    _______________________________________________
>>    OSRM-talk mailing list
>>    OSRM-talk at openstreetmap.org <mailto:OSRM-talk at openstreetmap.org>
>>    https://lists.openstreetmap.org/listinfo/osrm-talk
>> 
>> 
>> 
>> 
>> _______________________________________________
>> OSRM-talk mailing list
>> OSRM-talk at openstreetmap.org
>> https://lists.openstreetmap.org/listinfo/osrm-talk
>> 
> 
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk





More information about the OSRM-talk mailing list