[openstreetmap-website] About database setup (#978)

Thong-Hoang Dao notifications at github.com
Fri May 29 10:02:16 UTC 2015


At this time I post this question, everything is ok. But during installation process, I've met some problem that make me so confused.
1. I've built Postgresql from source, so I've ran it as instance in console. And when I ran the command: bundle exec rake db:create, it take the error that cannot connect to Postgres database, although I've set its setting to listen to all address and run in port 5432. So, I've had to install postgresql as service like your instructions and everything is ok. 

2. I've login as root user to build, and nothing happen until I run the three commands to create function: psql -d openstreetmap -c "CREATE FUNCTION .... The error has occured: libpgosm permission denied. I can't understand, I've ran everything as root user at the beginning and I've also create root role for postgres database. I've tried to login to the database as root role and ran the command but nothing changed. Maybe CREATE FUNCTION call to something that did not run as root?

Hope to see your help!

---
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/issues/978
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20150529/87784cdc/attachment.html>


More information about the rails-dev mailing list