[openstreetmap/openstreetmap-website] Enable the app to be built using Docker (#1290)

Seth Fitzsimmons notifications at github.com
Mon Oct 31 21:21:58 UTC 2016


mojodna commented on this pull request.



> +RUN apt-get install -y --no-install-recommends ruby-dev
+RUN apt-get install -y --no-install-recommends libxml2-dev
+RUN apt-get install -y --no-install-recommends libxslt1-dev
+RUN apt-get install -y --no-install-recommends libpq-dev
+RUN apt-get install -y --no-install-recommends libsasl2-dev
+RUN apt-get install -y --no-install-recommends imagemagick
+RUN apt-get install -y --no-install-recommends libmagickwand-dev
+RUN apt-get install -y --no-install-recommends nodejs
+RUN apt-get install -y --no-install-recommends file
+RUN apt-get install -y --no-install-recommends postgresql-client
+RUN apt-get install -y --no-install-recommends locales
+RUN apt-get clean && rm -rf /var/lib/apt/lists/*
+
+# Setup app location
+RUN mkdir -p /app
+WORKDIR /app

Also consider creating/running as an unprivileged user.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/pull/1290#pullrequestreview-6528171
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20161031/320e4e30/attachment.html>


More information about the rails-dev mailing list