[Talk-de] JOSM sehr träge

SLXViper SLXViper at gmx.net
Mo Mai 4 21:33:37 UTC 2009


Frag mich nicht warum das so ist, ich hab das nur beobachtet, als das
Oberpfalzprojekt lief. Dort konnte ich sehr bald kaum noch was machen,
weil alles extrem träge lief. Wenn ich einen Weg gezeichnet habe, wurde
er erst Sekunden später überhaupt mal angezeigt, die
Gummiband-Verbindungslinie musste ich abschalten, weil sie viel zu spät
kam. Die CPU-Auslastung hing dann konstant auf vollen 100%. Zum
Vergleich hab ich mal andere Quellen geladen, bei denen das nicht
passiert ist. Landsat geht superflüssig, die (leider noch nicht zum
Abzeichnen nutzbaren) Graustufen-2m-Luftbilder vom Vermessungsamt BaWü,
auf denen ich mal zum Testen kreuz und quer Muster gemalt hab, haben
auch nicht so stark gebremst, bei hochauflösenden yahoo-Bilder hatte ich
auch kaum Probleme.
Java ist eben auch nicht gerade die beste Sprache, was Performance angeht...

Grüße

Stephan Wolff schrieb:
> SLXViper schrieb:
>   
>> Bei mir läuft JOSM recht flüssig auf nem T41 mit 1,4GHz und ATi Mobility
>> 7500, nur mit dem wmsplugin wird es manchmal sehr lahm, das verursacht
>> je nach Datenquelle bis zu 100% CPU-Dauerlast. Rein an der Hardware
>> liegt es wohl nicht, ich vermute, es liegt an etwas anderem.
>>     
>
> Das wmsplugin habe ich auch in Gebrauch. Ich hatte angenommen, dass ein
> einmal geladenes Hintergrundbild ähnlich dem Desktopbild keine 
> nennenswerte CPU-Last mehr verursacht, aber ich werde es einmal ohne 
> ausprobieren. Aber wieso kann die CPU-Last von der Datenquelle abhängen?
>
> Viele Grüße
>
> Stephan
>
>
> _______________________________________________
> Talk-de mailing list
> Talk-de at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/talk-de
>
>   





Mehr Informationen über die Mailingliste Talk-de