[OSM-talk-fr] Erreur sur le flux WMS du CRAIG

Landry Breuil landry.breuil at gmail.com
Mar 27 Sep 09:56:53 UTC 2011


2011/9/27 Sébastien Dinot <sebastien.dinot at free.fr>:
> Nicolas Dumoulin a écrit :
>> le WMS ne répond pas en Mercator, ce qui doit être indiqué sur le wiki
>
> Pourtant, quand j'exécute la requête :
>
> wget -O result.xml 'http://wms.craig.fr/osm?service=wms&request=getcapabilities'
>
> La réponse du serveur indique le contraire. Voici un extrait :
>
> ------------------------------------------------------------------------
>    <Layer>
>      <Name>auvergne</Name>
>      <Title>Auvergne 30cm</Title>
>      <Abstract>Orthophotographie a 30cm de resolution sur la region Auvergne</Abstract>
>      <Layer queryable="0" opaque="0" cascaded="0">
>        <Name>auvergne_30cm</Name>
>        <Title>Auvergne a 30 cm < 1:25000</Title>
>        <Abstract>Couche haute definition affichee en dessous de 1:25000</Abstract>
>        <CRS>EPSG:2154</CRS>
>        <CRS>EPSG:4326</CRS>
>        <CRS>EPSG:3785</CRS>
>        <CRS>EPSG:3857</CRS>
>        <CRS>EPSG:900913</CRS>
>        <CRS>EPSG:4171</CRS>
> ------------------------------------------------------------------------
>
> Or, si le code EPSG:4326 correspond à la projection que JOSM nomme
> WGS84, le code EPSG:3857 correspond bien à la projection Mercator, non ?

Oui, les précedents flux ne faisaient que du Lambert 93, j'ai ajouté
les autres projections lors de l'intégration de la haute loire et du
cantal.

Ca ne me donne toujours pas assez d'info pour savoir ce qui ne marche
pas.. peux tu savoir quelles sont les requetes faites ?
Sous linux/unix, josm ecrit les requetes WMS sur la console d'ou il a
été lancé.. ou alors donne moi ton ip, j'irai fouiller dans les logs
du serveur.
En tout cas le message d'erreur en java vient bien de josm, ce n'est
pas du coté de mapserver..

Landry




Plus d'informations sur la liste de diffusion Talk-fr