[OSM-talk-fr] Route500 et le passage à 80 km/h du 1er juillet...

Jérôme Amagat jerome.amagat at gmail.com
Mer 11 Juil 12:52:48 UTC 2018


Les maxspeed=80 augmentent dans osm?
Il y a-t-il un moyen de "voir" le passage de 90 à 80 dans osm?
Il y a ITO map qui permet de visualiser les maxspeed (je sais pas si c'est
toujours mis a jour et tout les combien) mais 80 et 90 c'est la même
couleur :(
J'ai vu ça sur la page maxspeed du wiki :
http://mijndev.openstreetmap.nl/~peewee32/maxspeed/Maxspeed.htm
mais il faut beaucoup zoomé pour voir les limites de vitesse :(

Sinon j'ai fait les modification autour de chez moi (en gros sur un quart
de département autour de Bourg en Bresse dans l'Ain), retour sur expérience
:
j'ai modifié là où il y avait déjà un maxspeed=90

1ere chose, il ne reste plus grand chose à 90 :( , presque tout ce qui
était limité à 90 passe à 80, il va falloir ralentir :(

j’avais déjà mis le tag lanes=* sur presque toutes les routes primary et
autour de chez moi (sûrement comme partout en France hors région parisienne
et grandes villes) hors agglo il n'y a que les autoroutes et des primary
qui ne sont pas à 2 voies (2x1voie) donc changement de partout en
maxspeed=80 lorsqu'il y avait un maxspeed=90 sauf si :
- chaussées séparées alors je ne change rien
- 2x2 voie sans chaussées séparées ça reste à 90
- 3 voies alors enlever le maxspeed=90 et ajouter maxspeed:forward=90 et
maxspeed:backward=80 (ou l'inverse suivant le coté où il y a 2 voies)

avec overpass turbo il y a moyen de faire déjà un bon tri. on peut envoyé
dans josm les routes avec maxspeed=90 qui ne sont pas en sens unique et pas
à 4 voies :
https://overpass-turbo.eu/s/AcV

[out:xml][timeout:500];
way["highway"]["maxspeed"="90"]["oneway"!="yes"]["oneway"!="-1"]["lanes"!="4"]({{bbox}});
out meta;>;out meta qt;

si c'est pas une primary, on peut changer sans trop de problème le maxspeed
de 90 à 80 (avec un petit coup d’œil sur la vue aérienne pour être sur :) )

Il y a certaines routes qui posent problèmes, par exemple :
les entrées et sorties de rond point, on a souvent des chaussées séparées
par un petit "truc" mais c'est quand même limité à 80 si il n'y a qu'une
voie dans chaque sens (je sais pas si en fait c'est pas 110, les routes
sont à chaussées séparées :) )
Pareil pour certains bouts de routes souvent proche d'intersection qui sont
à chaussées séparées mais que j'ai passé à 80 si une voie dans chaque sens.
Si il y a plus d'une voie dans chaque sens mais qu'il y a qu'une voie qui
sert a aller "tout droit" (le reste pour tourner à droite ou/et à gauche)
alors j'ai fait comme si il n'y avait qu'une voie et donc passage à 80.

Après tout cela j'ai chargé avec overpass turbo tout ce qui avait
maxspeed=90 pour voir si j'avais oublié certaines choses.
[out:xml][timeout:500];
way["highway"]["maxspeed"="90"]({{bbox}});
out meta;>;out meta qt;

bien utile vu que j'avais oublié quelques petits bouts de routes :)
(intersection, pont)

Il faut regarder aussi les "autres choses" qui ont maxspeed=90, avec
overpass turbo :
[out:xml][timeout:500];
nwr["maxspeed"="90"]({{bbox}});
out meta;>;out meta qt;

il y a des panneaux a modifié traffic_sign=* (j'ai pas eu à le faire vu que
je les ajoute pas dans osm et que la plupart des maxspeed dans ma zone
c'est moi qui les avait ajouté :) les seul que j'ai sont sur autoroute donc
pas touché)
Il y a aussi les radars, j'ai pas fait les modifications il faut que je
regarde mieux comment il faut les taguer j'ai l'impression que certaines
relations sont cassé (autre problème : comment on fait quand la limite est
différente suivant le sens et que l'on ne sais pas si il photographie dans
les 2 sens ? :) )

J'en fini en faisant un petit aparté avec osmose :
Christian, ça serait bien de remettre l'analyse osmose pour les lanes :P,
c'est le serveur qui a laché qui s'en occupait? je sais pas si c'est prévu
de remettre en place l'analyse?
Il y a des erreurs a corrigé sur les routes et les lanes dans osmose :
http://osmose.openstreetmap.fr/fr/errors/?item=3160
et d'autre sur d'autres problème sur les routes.

D'autres problèmes pourraient être indiqués comme erreurs, 2 suggestions :
- les routes à 3 voies avec maxspeed:forward=90 et maxspeed:backward=80 (ou
l'inverse) vérifier que c'est bien là ou il y a 2 voies que c'est limité à
90. c'est assez facile de ce tromper et d'inverser :)
- pas grand chose a voir avec les maxspeed : les highway=primary avec
lanes=1 sans sens unique, j'en ai trouvé et la plupart du temps c'est des
erreurs (pas toujours, dans de très rare cas. il y a des bouts de routes
souvent dans des villages pas suffisamment larges pour 2 voies) (peut être
aussi les secondary voir les tertiary?)
avec overpass :
[out:xml][timeout:500];
way["highway"="primary"]["oneway"!="yes"]["oneway"!="-1"]["lanes"="1"]({{bbox}});
out meta;>;out meta qt;
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://lists.openstreetmap.org/pipermail/talk-fr/attachments/20180711/02aa2b4e/attachment.html>


Plus d'informations sur la liste de diffusion Talk-fr