[Talk-us] Check your turn:lanes

Jack Burke burkejf3 at gmail.com
Thu Aug 25 16:04:48 UTC 2016


Even if the road isn't signed that way?  The use of "through" when there is
no explicit marking to that effect seems to be contraindicated by the wiki.

Don't get me wrong--I don't see why we _couldn't_ use it when that is the
obvious traffic direction, even with the lack of explicit signage.  But if
that's how we want to use "through" then shouldn't we update the wiki to be
more clear?



On Thu, Aug 25, 2016 at 10:58 AM, Paul Johnson <baloo at ursamundi.org> wrote:

> On Wed, Aug 24, 2016 at 5:19 PM, Jack Burke <burkejf3 at gmail.com> wrote:
>
>> An active OSM group (leaving names, etc. out while they check out what I
>> reported) is running a script or plug-in or challenge called "to-fix" that
>> is apparently supposed to help fix incorrect turn:lanes values (and maybe
>> other things, I haven't investigated deeply enough).
>>
>> The problem is, it's breaking the values instead.  I found a section of
>> road that I'd added turn:lanes to in order to provide lane guidance at an
>> exit.  My original value of "none|none|none|none|none;slight_right" was
>> replaced by "||||slight_right".
>>
>
> You may want to try through|through|through|through|through;slight_right
> as the value; I've noticed routers that actually use this data struggle
> with null or none values, which isn't *entirely* unreasonable, but the
> former does describe the allowed movements even if the DOT doesn't feel the
> need to explicitly paint it out.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk-us/attachments/20160825/b264b76c/attachment.html>


More information about the Talk-us mailing list