[Openstreetmap] pop goes the segment

Lars Aronsson lars at aronsson.se
Sun Dec 4 22:34:41 GMT 2005


I'm drawing a map like usual, using the applet.  I place dots, 
then I draw line segments.  After 10 or 20 seconds, some of the 
segments go away, without me doing anything.  Sometimes they leave 
white dots, sometimes black ones.  This seems to happen all the 
more often in the recent days.

Sometimes the segments disappear when I pan, sometimes they 
disappear infront of my eyes when I do nothing.

Dot moves are also undone.  It is as if the server is 
asynchronously refreshing the applet and reminding it that the 
modifications never went through.

Must I go back and check all the maps I've drawn lately to see if 
any of the segments didn't stick?  That's unacceptable.  If I draw 
something, it should stay there until someone deletes it.

----

A far less irritating bug, one that I have learned to live with, 
is that I have to double click the first click in the applet.  
After the applet starts, or after I pan or zoom, you would guess I 
could just click the dot tool and then place the first dot.  But 
no.  If the first click is on the dot toll, the second click will 
not place a dot, but the third one will.  Or if the first click is 
anywhere on the canvas (without having picked a tool) and the 
second click is on the dot tool, then the third click will place a 
dot.

----

Here is a suggestion for improvement: If I draw a line segment and 
drop it off where there is no dot, no line is drawn.  If instead a 
dot was silently placed where I drop the segment, I would not have 
to place dots before I draw lines.


-- 
  Lars Aronsson (lars at aronsson.se)
  Aronsson Datateknik - http://aronsson.se




More information about the talk mailing list