[OSM-talk] Server error in osmeditor2

Andrew Findlay andrew at findlay.org
Tue Apr 11 19:06:31 BST 2006


On Tue, Apr 11, 2006 at 07:00:16PM +0100, Andrew Findlay wrote:

> Sometimes I get a server error or a
> silent refusal to create segments in the middle of a session. I will
> try to narrow down the cases that cause this.

I append the debug output leading up to a server error incident. I was
creating segments at the time, in live-update mode.

The last two segments are still shown dotted. It is possible to recover
by deleting and re-adding the last couple of nodes.

Andrew
-- 
-----------------------------------------------------------------------
|                 From Andrew Findlay, Skills 1st Ltd                 |
| Consultant in large-scale systems, networks, and directory services |
|     http://www.skills-1st.co.uk/                +44 1628 782565     |
-----------------------------------------------------------------------
scheduleCommand(): pushing back a request:PUT /api/0.3/segment/0
before push_back: length of requests now=1
after push_back: length of requests now=2
length of requests now=1
responseReceived(): sending the next request:PUT /api/0.3/segment/0
length of requests now=1
Making request: host: www.openstreetmap.org requestType: PUTURL :/api/0.3/segment/0
SENDING: <osm version='0.3'>
<segment from='687864' to='687865'  id='0'>
<tag k='foot' v='yes' />
<tag k='horse' v='yes' />
<tag k='bike' v='yes' />
<tag k='car' v='yes' />
<tag k='class' v='primary' />
</segment>
</osm>

curReqId is  26
doing erase
done
response: id=26 error=0
RESPONSE RECEIVED!
popping the front request
NEW UPLOADED SEGMENT IS NOT NULL::SETTING ID
ID IS: 641106
DONE.
length of requests now=0
********setting emitdata**********
Making request: host: www.openstreetmap.org requestType: PUTURL :/api/0.3/node/0
SENDING: <osm version='0.3'>
<node lat='51.41248038' lon='-0.7999676094' id='0' >
<tag k='class' v='node'/>
</node>
</osm>

curReqId is  28
scheduleCommand(): pushing back a request:PUT /api/0.3/node/0
before push_back: length of requests now=0
after push_back: length of requests now=1
********setting emitdata**********
doing erase
done
response: id=28 error=0
RESPONSE RECEIVED!
popping the front request
**** HANDLING A NEW NODE RESPONSE ****
STR=687866

ids[0]=687866
NEW UPLOADED NODE IS NOT NULL::SETTING ID
DONE.
***********emitting signal**************
doaddseg()
xml is: <osm version='0.3'>
<segment from='-6093' to='-6094'  id='0'>
<tag k='foot' v='yes' />
<tag k='horse' v='yes' />
<tag k='bike' v='yes' />
<tag k='car' v='yes' />
<tag k='class' v='primary' />
</segment>
</osm>

scheduleCommand(): pushing back a request:PUT /api/0.3/segment/0
before push_back: length of requests now=1
after push_back: length of requests now=2
length of requests now=1
responseReceived(): sending the next request:PUT /api/0.3/segment/0
length of requests now=1
Making request: host: www.openstreetmap.org requestType: PUTURL :/api/0.3/segment/0
SENDING: <osm version='0.3'>
<segment from='-6093' to='-6094'  id='0'>
<tag k='foot' v='yes' />
<tag k='horse' v='yes' />
<tag k='bike' v='yes' />
<tag k='car' v='yes' />
<tag k='class' v='primary' />
</segment>
</osm>

curReqId is  30
doing erase
done
Error encountered





More information about the talk mailing list