[OSM-talk] Sudden ugliness with t at h street names

Robert Hart bathterror at gmail.com
Thu Apr 5 18:32:06 BST 2007


>
> Hi,
>
>     have a look at the road "Wielandtstraße" in the middle of this
> tile, as rendered a few days ago on my machine:
>
> http://openstreetmap.gryph.de/slippymap/tiles/
> osmarender4/16/34299/22505.png
>
> Now this is how it currently looks on the dev server:
>
> http://dev.openstreetmap.org/~ojw/Tiles/tile.php/16/34299/22505.png
>
> Note how the street name suddenly begins in the middle of the street
> rather than at the left (even though the street has only one segment
> and so cannot be badly ordered). Also note how "Wielandtstraße" and
> "Philip-Reis-Straße" street names on the second tile look ugly, a bit
> bolder than the others, while on the first tile, all fonts look the
> same.
>
> Does anybody have an idea why this is so?
>
>
There seems to be quite a variety in output quality depending on
T at Hinstallation. I suspect the biggest culprit is missing fonts,
especially on
windows boxes, but also no doubt on inkscape version, and version of
libraries inkscape links against. Perhaps it's time we created a test suite,
and periodically get each client to render it?

The problems are most noticeable when adjacent tiles are rendered by
different clients.

I'm not sure how easy it is to tell which client software was used on any
given tile, as for example, I have t at h running on both a windows XP and
debian sid box under a single user name.

Rob

p.s. are you absolutely sure there is only one segment in the way. I don't
see how that could have happened otherwise....
-- 
Robert Hart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk/attachments/20070405/db61ab60/attachment.html>


More information about the talk mailing list