[OSM-talk] planet files appear truncated to osmosis, was: old planet files with 'nolt' in the name

Martijn van Exel m at rtijn.org
Sun Jan 15 16:31:01 GMT 2012


I had the following issue with processing a planet file:

On Sat, Jan 14, 2012 at 11:32 AM, Martijn van Exel <m at rtijn.org> wrote:
> Also, I'm running into problems with the Jan 6, 2010 planet:
> org.openstreetmap.osmosis.core.OsmosisRuntimeException: Unable to
> parse xml file /osm/planet/historical/planet-100106.osm.bz2.
> publicId=(null), syst
> emId=(null), lineNumber=4312, columnNumber=75.
> The MD5 hash check was OK.
> Anyone had trouble with this particular file before?

It seems that the problem is not with the particular file. I tried the
same process with a few other files, all give the same error around
line 4000. I'm officially confused. I used osmosis a lot before on the
same machine.

This is what I am doing:

mvexel at lima$  /osm/software/osmosis-0.39/bin/osmosis --rx
/osm/planet/historical/planet-090701.osm.bz2 --bp
file=/osm/poly/us.poly --wb

I tried osmosis 0.39 and 0.40.1 with the same result.
martijn van exel
geospatial omnivore
1109 1st ave #2
salt lake city, ut 84103

More information about the talk mailing list