[OSM-talk] Help with JOSM and OS X Yosemite

Clifford Snow clifford at snowandsnow.us
Thu Jul 30 14:18:13 UTC 2015


On Tue, Jul 28, 2015 at 10:21 PM, Suzan Reed <suzan at suzanreed.com> wrote:

> I’ve tried all the usual fixes in the preferences, but can not get JOSM to
> connect with the server on my new Mac running OS X Yosemite. It may be a
> system thing. Anyone out there that can help?
>

Suzan,
It doesn't look like anyone has tried to help. I run JOSM on an Mac
upgraded to Yosemite. This was a fresh install of Yosemite. An upgrade to
Yosemite may behave differently.

Have you verified that java is installed? Use
https://www.java.com/en/download/installed.jsp - A browser that supports
flash is needed for this test. I used Safari to verify that the latest
version was installed.

See if you can run JOSM from the command line,
cd /Applications/JOSM.app/Contents/Java
ls *.jar #use the output for the next command. Replace josm-latest.jar with
your .jar file
java -jar josm-latest.jar

If running from the command line works, but not from Finder, I would remove
JOSM.app and reinstall.

Let me know if you need additional assistance.

Clifford




-- 
@osm_seattle
osm_seattle.snowandsnow.us
OpenStreetMap: Maps with a human touch
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk/attachments/20150730/73660b91/attachment.html>


More information about the talk mailing list