[OSM-talk] Help with JOSM and OS X Yosemite

Suzan Reed suzan at suzanreed.com
Thu Jul 30 19:21:01 UTC 2015


Marc, I thought I replied saying I didn’t know where the OS X console for logging was. I will look at it, but don’t know where to find it. 

Clifford, I am running Java 8 build 51.
JOSM app, version 8491
New Macbook Pro OS X Yosemite
No proxy servers in any browser or in the system preferences

I can test access the OpenStreetMap API in a browser and see xml: http://api.openstreetmap.org/api/0.6/way/93710880
And here with a secure connection: https://api.openstreetmap.org/api/0.6/way/93710880

In JOSM I have
* chosen the JOSM menu (top left)
* chosen 'preferences...'
* on the icons running down the side, I’ve chosen the second one which looks like a globe
* checked 'Use the default OSM server URL (https://api.openstreetmap.org/api)
and I’ve entered my OSM username and password.

No joy. Would love to run JOSM on this computer. 

Suzan 


On Jul 30, 2015, at 7:35 AM, Marc Gemis <marc.gemis at gmail.com> wrote:

Clifford, I probably only replied to Suzan the first time. She got back to me with some details.

Java 8 & JOSM version seem OK. It has something to do with the network connection, although browser can connect and no proxy involved.
The error in the dialog says java.net.ConnectException: No Route to host

And a text asking to check the proxy.

I had no clue what else could be checked. I asked her to look in the OSX console for logging. She did not reply on that yet.


regards

m

On Thu, Jul 30, 2015 at 4:18 PM, Clifford Snow <clifford at snowandsnow.us> wrote:

On Tue, Jul 28, 2015 at 10:21 PM, Suzan Reed <suzan at suzanreed.com> wrote:
I’ve tried all the usual fixes in the preferences, but can not get JOSM to connect with the server on my new Mac running OS X Yosemite. It may be a system thing. Anyone out there that can help?

Suzan,
It doesn't look like anyone has tried to help. I run JOSM on an Mac upgraded to Yosemite. This was a fresh install of Yosemite. An upgrade to Yosemite may behave differently. 

Have you verified that java is installed? Use https://www.java.com/en/download/installed.jsp - A browser that supports flash is needed for this test. I used Safari to verify that the latest version was installed.

See if you can run JOSM from the command line,  
cd /Applications/JOSM.app/Contents/Java
ls *.jar #use the output for the next command. Replace josm-latest.jar with your .jar file
java -jar josm-latest.jar

If running from the command line works, but not from Finder, I would remove JOSM.app and reinstall.

Let me know if you need additional assistance. 

Clifford




-- 
@osm_seattle
osm_seattle.snowandsnow.us
OpenStreetMap: Maps with a human touch

_______________________________________________
talk mailing list
talk at openstreetmap.org
https://lists.openstreetmap.org/listinfo/talk






More information about the talk mailing list