[Tile-serving] [osm2pgsql] Providing Windows binaries/packages (#17)

Jason Huntley notifications at github.com
Thu Apr 11 15:55:21 UTC 2013

Not sure if it helps, but here are my notes on the postgres configuration:
Tune Parameters for postgresql.conf

   - autovacuum = off
   - checkpoint_segments = 20
   - shared_buffers = 512MB # min 128kB
   - work_mem = 256MB # min 64kB
   - maintenance_work_mem = 512MB # min 1MB
   - synchronous_commit = off

Import example:

osm2pgsql.exe -v -c -d osm -U osm -W -H localhost -P 5432 -S default.style
-s -C 1600 --hstore --number-processes=4 -r pbf

I also have a recent build of osm2psql which works. I have some mapnik
debugging to get through on mingw64, but I'll make it all available to our
build server here:


The next build will have a package you can download under the Artifacts tab:


Is there a specific time-frame you need this?

On Thu, Apr 11, 2013 at 2:18 AM, emirhartato <notifications at github.com>wrote:

> @apmon <https://github.com/apmon> can you explain how to set database
> parameters? Hopefully if that can help solve the problem. There were 6
> laptops tested and all of them have same error log. I also did a fresh
> install of PostgreSQL and PostGIS and create a new database, but still have
> the same error log.
>> Reply to this email directly or view it on GitHub<https://github.com/openstreetmap/osm2pgsql/issues/17#issuecomment-16218534>
> .

Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tile-serving/attachments/20130411/5db5a06c/attachment.html>

More information about the Tile-serving mailing list