[Tile-serving] [mod_tile] Incorrect ubuntu renderd.conf plugins_dir (#21)

pnorman notifications at github.com
Tue May 14 03:03:12 UTC 2013


Off of a clean install I got the error 

```
An error occurred while loading the map layer 'default': Could not create datasource. No plugin found for type 'shape' (searched in: /usr/lib/mapnik/2.1/input
```

I traced this to an incorrect ``plugins_dir`` in renderd.conf and set ``plugins_dir=/usr/lib/mapnik/input`` but this should be set by default.

https://github.com/openstreetmap/mod_tile/issues/2#issuecomment-15929652 suggests ``mapnik-config --input-plugins`` but a minimal install doesn't have ``mapnik-config`` which is part of ``libmapnik2-dev``

---
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/mod_tile/issues/21
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tile-serving/attachments/20130513/4f8dc2a6/attachment.html>


More information about the Tile-serving mailing list