[OSM-dev] Using the API from the dev server: is it possible?

Tommy Persson tpe at ida.liu.se
Wed Jul 19 20:48:36 BST 2006


Immanuel Scholz <immanuel.scholz at gmx.de> writes:

> But currently, the mysql-schema file is out of sync with the server ruby
> code. So until someone fix this (e.g. by running "mysqldump -d osm" on
> the production machine), any attempts to speak with your testserver will
> be futile. :-(

OK.  But this has been the case some weeks now if I remember
correctly.  I am interesting in learning about the server so I can
help developing things.  But not being able to setup a testserver is
kind of bad for the enthusiasm...

> 
> 
> > The configuration file do:
> > 
> >    RubyRequire apache/simple-auth
> > 
> > but I cannot fins the file simple-auth.rb anywhere?
> 
> That's bad. 
> 
> It should be under www.openstreetmap.org/ruby/api/apache/simple-auth.rb
> within the subversion (this is not an url, but a path into subversion
> archive! ;)

Found it...  I forgot .rb when I did a find.  I have set path to it
but I still get errors:

  [Wed Jul 19 21:46:38 2006] [notice] Apache/2.0.55 (Debian) mod_python/3.2.8 Pyth
  on/2.3.5 PHP/4.4.2-1.1 proxy_html/2.4 mod_ruby/1.2.6 Ruby/1.8.4(2005-12-24) conf
  igured -- resuming normal operations
  [Wed Jul 19 21:46:38 2006] [error] mod_ruby: failed to require apache/simple-aut
  h
  [Wed Jul 19 21:46:38 2006] [error] mod_ruby: error in ruby
  [Wed Jul 19 21:46:38 2006] [error] mod_ruby: /home/tompe/osm/svn/www.openstreetm
  ap.org/ruby/api/osm/osmlog.rb:3:in `load': no such file to load -- servinfo.rb (
  LoadError)
  [Wed Jul 19 21:46:38 2006] [error] mod_ruby:   from /home/tompe/osm/svn/www.open
  streetmap.org/ruby/api/osm/osmlog.rb:3


-- 
/Tommy Persson




More information about the dev mailing list