[OSM-dev] OSM tools RPMs for Fedora Core 6

Sander Hoentjen sander at hoentjen.eu
Mon Mar 26 21:40:53 BST 2007


On Mon, 2007-03-26 at 21:12 +0100, Keith Sharp wrote:

> > Also it doesn't currently build on x86_64:
> > scons: Reading SConscript files ...
> > Checking for main() in C library m... yes
> > Checking for main() in C library ltdl... no
> > Could not find header or shared library for ltdl, exiting!
> 
> Following Jons lead it turns out this is a missing BuildRequires:
> libtool-ltdl-devel was the problem.  I've updated the SPEC and RPMs,

Yes, that fixes that, but there seems to be other buildrequires missing,
i get errors like:
/usr/include/boost/python/numeric.hpp:90: error: 'PyObject' has not been declared
No time to look at it further now. hope this is enough info, otherwise i
will tell you more tomorrow.

Sander






More information about the dev mailing list