[OSM-dev] JOSM and API 0.6

Andy Allan gravitystorm at gmail.com
Wed Apr 1 19:29:10 BST 2009


On Wed, Apr 1, 2009 at 7:10 PM, Shaun McDonald
<shaun at shaunmcdonald.me.uk> wrote:
>
> On 1 Apr 2009, at 18:53, Andy Allan wrote:
>
>> On Tue, Mar 31, 2009 at 9:24 AM, Frederik Ramm <frederik at remote.org>
>> wrote:
>>>
>>> marcus.wolschon at googlemail.com wrote:
>>>>
>>>> By default the config-setting "osm-server.additional-versions" is not
>>>> set at all, thus it only accepts "0.5".
>>>> You have to manually set "osm-server.additional-versions" to "0.6"
>>>> to accept both. That is only possible with a text-editor or
>>>> in advanced-settings (the Einstein-Icon).
>>>
>>> Yes, but if you want to allow uploads to a 0.6 server then you have to
>>> set osm-server.version=0.6.
>>
>> So if someone downloads and starts using JOSM today, will it
>> automatically switch over next month when the API changes, or will
>> users need to fiddle their config?
>>
>
> No.
>
> They currently need to fiddle with the config. I believe that on the first
> day of the API being down JOSM will be updated to by default use 0.6, at
> which point no more fiddling will be needed. I believe that Merkaartor is
> the same, though the fiddling is a lot simpler.
>
> I'm happy to be corrected if I'm wrong.

Gah, that sounds less than optimal. If the app is capable of talking
to either 0.6 or 0.5 it would be nice if it would try both or fallback
or make a capabilities call or similar.

Cheers,
Andy




More information about the dev mailing list