[OSM-dev] type "four_byte_unsigned" does not exist

Shaun McDonald shaun at shaunmcdonald.me.uk
Tue May 26 23:49:18 BST 2009


Do all the tests run? That will show if there are any problems with  
your setup.

Is there anything in the data that would cause this problem?

Shaun

On 26 May 2009, at 23:40, Jeffrey Warren wrote:

> OK I managed to get it booted, but I encountered this error in rails:
>
> ####################################
> NoMethodError in ApiController#map
>
> You have a nil object when you didn't expect it!
> The error occurred while evaluating nil.visible?
> RAILS_ROOT: /Users/eco/Sites/openstreetmap
>
> Application Trace | Framework Trace | Full Trace
> app/models/relation.rb:128:in `to_xml_node'
> app/models/relation.rb:119:in `to_xml_node'
> app/controllers/api_controller.rb:185:in `map'
> app/controllers/api_controller.rb:184:in `each'
> app/controllers/api_controller.rb:184:in `map'
> Request
>
> Parameters:
>
> {"bbox"=>"12.4502,
> 41.861,
> 12.5341,
> 41.9227"}
>
> ####################################
>
> I fixed it by modifying this line in relation.rb, to check if  
> member.member is nil before evaluating .visible?
>
> This may be a very special case and doesn't need to be committed...  
> but I'm not that familiar with the codebase so just tell me if I  
> should submit this to Trac or whatever.
>
> # /app/models/relation.rb:128
>
> # if member.member.visible?
> if member.member && member.member.visible?
>
> Jeff
>
>
>
> On Tue, May 26, 2009 at 3:33 PM, Thomas Wood <grand.edgemaster at gmail.com 
> > wrote:
> 2009/5/26 Tom Hughes <tom at compton.nu>:
> > Dan Karran wrote:
> >> I'm trying to set up a copy of the rails site on my machine, using
> >> Postgres, but I'm running into a problem on the initial  
> db:migrate ...
> >> can anyone point me to how to fix this?
> >
> > It's a bug, related to a change of some sort in rails 2.2 (it used  
> to
> > work as is in 2.1). Add a require of lib/migrate to the top of that
> > migration (as some of the others already have) and it will work.
> >
> > The fix is already on the i18n branch but not on the head right now.
> >
> > Tom
>
> I've merged the fix across to head.
>
> --
> Regards,
> Thomas Wood
> (Edgemaster)
>
> _______________________________________________
> dev mailing list
> dev at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/dev
>
> _______________________________________________
> dev mailing list
> dev at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20090526/b219bc8b/attachment.html>


More information about the dev mailing list