[OSM-dev] OAuth - 401 Authorization Required (OAuth::Unauthorized)

Christoph Bünte tiny-grasshopper at gmx.net
Fri Sep 24 18:47:09 BST 2010


Hi,

today a user on wheelmap.org complained about getting an "authorization required" error when authenticating his osm account via oauth.

I had a look into this issue and tried it my account. Result was the same error. So i went to the osm oauth example and ran the example code (http://wiki.openstreetmap.org/wiki/OAuth/Examples) to make sure everything was ok with osm, but it wasn't. I get the following errror:

First, go register a new application at 
http://api06.dev.openstreetmap.org/oauth_clients/new
Tick the appropriate boxes
Enter the consumer key you are assigned:
Qdd20eq7Bk28EINIINHFsA
Enter the consumer secret you are assigned:
ZdtKqK3fIOsAYVwGpw9NkCcIju1fLF13kac8rMvjY
Your application is now set up, but you need to register
this instance of it with your user account.
Visit the following URL, log in if you need to, and authorize the app
http://api06.dev.openstreetmap.org/oauth/authorize?oauth_token=ai6dBNYq1QBslJrTRKK0bw
When you've authorized that token, press enter.

Converting request token into access token...
/opt/ruby-enterprise-1.8.7-2009.10/lib/ruby/gems/1.8/gems/oauth-0.4.0/lib/oauth/consumer.rb:215:in `token_request': 401 Authorization Required (OAuth::Unauthorized)
	from /opt/ruby-enterprise-1.8.7-2009.10/lib/ruby/gems/1.8/gems/oauth-0.4.0/lib/oauth/tokens/request_token.rb:18:in `get_access_token'
	from script/oauth_test:45

Users who already authorized their app can use oauth mechanism perfectly. Just the authorization process seems to be fucked.

Am I the only one with this problem?

Any help is appreciated. Thank you very much.

Christoph


More information about the dev mailing list