[OSM-dev] Kosmtik rendering issues

Yohan Boniface yohanboniface at free.fr
Tue Apr 7 15:18:24 UTC 2015


We had a similar discussion on the Github issues some days ago:

https://github.com/gravitystorm/openstreetmap-carto/issues/657#issuecomment-78665177

I was not able to really determine the origin of this difference, but 
the main suspicion is a difference in the used Mapnik. Of course, it can 
also be a bug on Kosmtik ;)

I've create an issue on the Kosmtik side to track any more info one of 
you may have:

https://github.com/kosmtik/kosmtik/issues/57

I was in a field mission in Jordan, so I was not really active on this 
issue, and I'm sorry for that. I'm back from today, I'm expecting a 
speed week now, but then I'll have a bit more time to dig in if still 
needed.

Also, side note, to compare renderings, I suggest this kosmtik plugin:

https://github.com/kosmtik/kosmtik-map-compare

Cheers,

Yohan


On 06/04/2015 12:42, Markus Mayr wrote:
> This is strange. It looks like some kind of scaling issue. Different
> Mapnik-Version? (mine is 2.3.0-pre ) Something like a
> negative-retina-tile parameter (somewhere)?
>
>
> Am 2015-04-06 um 09:59 schrieb nebulon42:
>> This is what I got:
>> http://i.imgur.com/isBTDCJ.jpg
>>
>> osm.org is much sharper.
>>
>> Am 2015-04-05 um 22:59 schrieb Markus Mayr:
>>> Same here. This screenshot displays my situation:
>>> http://i.imgur.com/HXBNP7W.png
>>>
>>>
>>> Am 2015-04-05 um 16:49 schrieb Matthijs Melissen:
>>>> On 5 April 2015 at 13:21, nebulon42 <nebulon42 at yandex.com> wrote:
>>>>> I started playing around with Kosmtik instead of TileMill. So far
>>>>> it works
>>>>> well, but I'm having two issues with the rendering:
>>>>>
>>>>> * Labels and symbols are cut off at metatile borders. As far as I
>>>>> understand
>>>>> there needs to be a metatile buffer. How can I set this in the config
>>>>> options?
>>>> I can confirm this issue, and I don't currently have a solution.
>>>>
>>>>> * Compared to openstreetmap.org my local tiles are more blurry.
>>>>> What can
>>>>> cause this? Or did I miss osm.org switching to high-res tiles?
>>>> This I cannot reproduce. Is everything more blurry, or certain
>>>> elements only?
>>>>
>>>> -- Matthijs
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev at openstreetmap.org
>>>> https://lists.openstreetmap.org/listinfo/dev
>>>
>>>
>>> _______________________________________________
>>> dev mailing list
>>> dev at openstreetmap.org
>>> https://lists.openstreetmap.org/listinfo/dev
>>>
>>
>> _______________________________________________
>> dev mailing list
>> dev at openstreetmap.org
>> https://lists.openstreetmap.org/listinfo/dev
>
>
> _______________________________________________
> dev mailing list
> dev at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/dev
>




More information about the dev mailing list