[HOT] Fwd: SDS Preparation/Project-Setup

Alex Rollin alex.rollin at gmail.com
Sat Oct 25 06:52:14 UTC 2014


I did my best to test SDS and I could not get it to work.  Below are my
findings.

Severin, Joseph, thank you to both of you for providing some direction.

I am doing my test with very slim json and preset definitions:
name/shop/category
I tried to save one point.

I have no idea what the problem is here.  The json is attached, same as in
the project definition, along with the presets, and the OSM test file.

*Details*

   1. I am using SDS plugin version 30416
   2. The plugin (seems) to ship with an incorrect server url, so I changed
   it to: http://sds.dev.hotosm.org
   3. I am on Windows 7 (yuck)
   4. User link: http://sds.dev.hotosm.org/users/5 (login:
   alex.rollin at gmail.com , password: duywUV6KVn ) (this account no longer
   works?  since password reset through web interface?
   5. My "user-5" account, created by Kate is a member of the correct
   project
   6. Project Link: http://sds.dev.hotosm.org/projects/9


*Save/Load Locally*

   1. When I save using the JOSM-SDS-menu-Save command the file cannot be
   saved to a network drive (no file appears at all). I can save to Desktop.
   I named the file with .osm extension but I don't know if that is correct or
   not, data remains readable in text editor, seems fine).
   2. When opening an SDS file from the Desktop I get a "Preparing data
   set" retrying through 5 of 5... and eventually a no data found error.
   3. My OSM test file is attached, along with presets and the JSON used.
   4. Using the SDS-menu_Load command JOSM cannot "see" the saved sds.osm
   file on the Desktop
   5. Manually entering the name of the file does not open the file.


*Data UL/DL*

   1. Any normal tags (non-sds-keyed tags) are saved to the OSM node, and
   uploaded to OSM as expected.
   2. All normal data and tags (non-sds-keyed data) can be downloaded again
   from OSM, as expected.
   3. No sds-keyed data is downloadable. Not expected.
   4. Saving sds-keyed-data with a normal OSM file removes all SDS data.  I
   think this is expected.
   5. Polygon (closed way building) and node (as building/shop) were tried,
   both failed to be retrieved from SDS server, but non-sds data was
   retrievable from OSM.


*Web Data Access*

   1. Through the SDS status page I can see that my original
   Kate-created-user can indeed save data to the SDS site:
   http://sds.dev.hotosm.org/status
   2. I cannot find any way to view or edit the data through the SDS site.
   All links to such pages throw 500 errors or access warnings.
   3. Searchby tag (ex shop) results in "no object is found" (there should
   be 2+ nodes and a closed way):
   http://sds.dev.hotosm.org/tagsearch?utf8=%E2%9C%93&change_project=9&tagstring=shop
   4. When I download the area again, after upload, the general tags for
   OSM are pulled down, but no data from SDS is available


*Users*

   1. Any user I make through the SDS site cannot verify credentials
   through JOSM, whether admin or normal. user. a 500 error is generated.
   2. Once I reset the password for my user-5 account, now I can no longer
   verify credentials through JOSM.  (!!!!!!!!!!)

--
Alex

---------- Forwarded message ----------
From: Alex Rollin <alex.rollin at gmail.com>
Date: Mon, Aug 4, 2014 at 6:34 PM
Subject: Re: [HOT] SDS Preparation/Project-Setup
To: Severin Menard <severin.menard at gmail.com>, Joseph Reeves <
iknowjoseph at gmail.com>


Severin, Joseph, thank you to both of you for providing some direction.

I am doing my test with very slim json and preset definitions:
name/shop/category
I tried to save one point.

I have no idea what the problem is here.  The json is attached, same as in
the project definition, along with the presets, and the OSM test file.

*Details*

   1. I am using SDS plugin version 30416
   2. The plugin (seems) to ship with an incorrect server url, so I changed
   it to: http://sds.dev.hotosm.org
   3. I am on Windows 7 (yuck)
   4. User link: http://sds.dev.hotosm.org/users/5 (login:
   alex.rollin at gmail.com , password: duywUV6KVn ) (this account no longer
   works?  since password reset through web interface?
   5. My "user-5" account, created by Kate is a member of the correct
   project
   6. Project Link: http://sds.dev.hotosm.org/projects/9


*Save/Load Locally*

   1. When I save using the JOSM-SDS-menu-Save command the file cannot be
   saved to a network drive (no file appears at all). I can save to Desktop.
   I named the file with .osm extension but I don't know if that is correct or
   not, data remains readable in text editor, seems fine).
   2. When opening an SDS file from the Desktop I get a "Preparing data
   set" retrying through 5 of 5... and eventually a no data found error.
   3. My OSM test file is attached, along with presets and the JSON used.
   4. Using the SDS-menu_Load command JOSM cannot "see" the saved sds.osm
   file on the Desktop
   5. Manually entering the name of the file does not open the file.


*Data UL/DL*

   1. Any normal tags (non-sds-keyed tags) are saved to the OSM node, and
   uploaded to OSM as expected.
   2. All normal data and tags (non-sds-keyed data) can be downloaded again
   from OSM, as expected.
   3. No sds-keyed data is downloadable. Not expected.
   4. Saving sds-keyed-data with a normal OSM file removes all SDS data.  I
   think this is expected.
   5. Polygon (closed way building) and node (as building/shop) were tried,
   both failed to be retrieved from SDS server, but non-sds data was
   retrievable from OSM.


*Web Data Access*

   1. Through the SDS status page I can see that my original
   Kate-created-user can indeed save data to the SDS site:
   http://sds.dev.hotosm.org/status
   2. I cannot find any way to view or edit the data through the SDS site.
   All links to such pages throw 500 errors or access warnings.
   3. Searchby tag (ex shop) results in "no object is found" (there should
   be 2+ nodes and a closed way):
   http://sds.dev.hotosm.org/tagsearch?utf8=%E2%9C%93&change_project=9&tagstring=shop
   4. When I download the area again, after upload, the general tags for
   OSM are pulled down, but no data from SDS is available


*Users*

   1. Any user I make through the SDS site cannot verify credentials
   through JOSM, whether admin or normal. user. a 500 error is generated.
   2. Once I reset the password for my user-5 account, now I can no longer
   verify credentials through JOSM.  (!!!!!!!!!!)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/hot/attachments/20141025/28f4b2aa/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: SDS_Kitchen_Building_test.osm
Type: application/octet-stream
Size: 762 bytes
Desc: not available
URL: <http://lists.openstreetmap.org/pipermail/hot/attachments/20141025/28f4b2aa/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Presets_routes_foundation_KITCHENSHOP.xml
Type: text/xml
Size: 1096 bytes
Desc: not available
URL: <http://lists.openstreetmap.org/pipermail/hot/attachments/20141025/28f4b2aa/attachment-0001.xml>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: sds_json_KITCHENSHOP.json
Type: application/json
Size: 360 bytes
Desc: not available
URL: <http://lists.openstreetmap.org/pipermail/hot/attachments/20141025/28f4b2aa/attachment-0001.json>


More information about the HOT mailing list