[OSRM-talk] hsgr error after many requests

Steven M. Ottens steven at minst.net
Wed Mar 23 01:11:02 UTC 2016


Hi Daniel,

I was using the development branch of osrm-backend and the standard (eg 
npm install osrm) version of node-osrm. Since I couldn't figure out how 
to get the correct version of node-osrm installed on the remote machine 
I redid the entire process with the master branch.

It works now, thanks for the help,

Steven

On 3/19/2016 5:14 AM, Daniel Hofmann wrote:
> Hm that sounds strange to me, too. What you're seeing is a failure in 
> matching the first couple of bytes (which represents a fingerprint).
>
> When you say
>
> > I find this weird since I have done the entire set before (with a 
> less elegant approach, but with the same *.osrm* files)
>
> could it be that you ran osrm-extract / osrm-prepare (in develop 
> branch now named osrm-contract) on .pbf files while on osrm-backend 
> version N.
> And now you updated osrm-backend to version N+x but you're still 
> feeding it the old .osrm files? This is so far the only way I can see 
> this happening.
>
> Can you try reproducing the issue by running the toolchain on your 
> .pbf extract.
> That is put away the .osrm files for a moment and generate fresh ones.
> Then run osrm-routed / node-osrm.
>
> Cheers,
> Daniel J H
>
> On Fri, Mar 18, 2016 at 10:14 PM, Steven M. Ottens <steven at minst.net 
> <mailto:steven at minst.net>> wrote:
>
>     Hi all,
>
>     I'm busy trying to build a program that, given a road network, a
>     series of villages and a series of POIs will calculate the time to
>     the nearest POI for each village. There are 215000 villages and
>     85000 POIs, so I split the region in smaller squares to speed up
>     the process, I end up with 500 squares and for each square I get
>     the villages within the square and the POIs within a buffer around
>     the square. I run these two through osrm.table to get the time to
>     the nearest POI.
>
>     This works fine and my server slowly chugs along until at some
>     point (after 15 minutes and a hundred+ squares) I get this error:
>
>     TypeError: hsgr input file misses magic number. Check or reprocess
>     the file
>
>     I find this weird since I have done the entire set before (with a
>     less elegant approach, but with the same *.osrm* files) and why
>     does this error only show up after a while.
>
>     If anyone has any insights I'd be much obliged,
>
>     Steven
>
>     _______________________________________________
>     OSRM-talk mailing list
>     OSRM-talk at openstreetmap.org <mailto:OSRM-talk at openstreetmap.org>
>     https://lists.openstreetmap.org/listinfo/osrm-talk
>
>
>
>
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20160322/3ecd340e/attachment.html>


More information about the OSRM-talk mailing list