[Talk-de] Grosse OSM Updates (ODBL, Posgresql, postgis,...)

Stephan Knauss osm at stephans-server.de
So Okt 7 14:07:43 UTC 2012


On 12.09.2012 11:02, Sven Geggus wrote:
> Stephan Knauss <osm at stephans-server.de> wrote:
>> PostgreSQL wurde gerade in 9.2 veröffentlicht. Gibt es etwas das dagegen
>> spricht?
> Eventuell, dass noch keiner damit Erfahrung hat? Im Prinzip sehe ich da aber
> kein problem. Ich werde den deutschen Tileserver wohl auch auf Postgresql
> 9.2/Postgis 2.0.1 Basis neu aufsetzen.

Aus der Erfahrung mit meinem Upgrade möchte ich noch ein paar Sachen 
ergänzen:
Die munin-scripte (zumindest bei debian bis inkl experimental)  können 
noch nicht mit 9.2. Das äußert sich in solchen Fehlern im Logfile:
ERROR:  column "procpid" does not exist
ERROR:  column "current_query" does not exist

Man kann aber problemlos die munin scripte gegen die ganz aktuellen 
Austauschen.


Wer eigene Abfragen auf die Daten geschrieben hat sollte mal prüfen ob 
er deprecated Funktionen von postgis verwendet. Entweder aktualisieren 
oder legacy.sql installieren. Meist sind es Funktionen die jetzt ein ST_ 
davor haben.




Warum der hstore mit osm2pgsql funktioniert weiss ich nicht. Eigentlich 
dürfte er das nicht, da es seit 9.2 den "=>" operator nicht mehr gibt. 
Sollte nun hstore('a=>b') oder 'a=>b'::hstore sein. Eventuell 
funktioniert das doch irgendwie aus dem Kontext heraus weil über COPY 
reingeschrieben wird. Wie robust das ganze ist kann ich nicht beurteilen.


Stephan






Mehr Informationen über die Mailingliste Talk-de