[Talk-GB] Rendering of disused railway stations

Richard Fairhurst richard at systemed.net
Thu Jan 17 22:50:44 GMT 2013


Bogus Zaba wrote:
> Anybody know where should this be reported as a rendering bug?

It's not so much a rendering bug, more a tagging discrepancy. The railway
stations in question are those tagged as

    railway=station; disused=yes

There are those who say (and I can see their point) that this is a really
dumb way of tagging things. It's effectively saying "This is a railway
station; OH NO IT'S NOT". It means every single client using OSM data has to
know about "disused=yes" and add an extra processing rule. If you're writing
a Mapnik stylesheet, that's an extra condition on pretty much every single
rule - disused pubs, disused stations, disused roads, and so on. OSM tagging
doesn't, and shouldn't, usually work like that.

So the better approach is to tag it differently. Unfortunately there isn't
really an agreed, simple way of doing this. Sometimes you'll see something
like

    railway=disused; disused=station

which (IMHO) is ugly, and means nothing can be two disused things at once
(which would be a problem if Stalybridge station and its pub were to close
;) ).

And, of course, this is OSM so there are always people who think the
solution is namespacing, aka liberal use of colons.
railway:historic=station_site seems mildly popular, but heck, that's
unwieldy.

Personally I like these simple variants reported by taginfo:

    railway=disused_station
    railway=abandoned_station
or even
    historic=station

cheers
Richard





--
View this message in context: http://gis.19327.n5.nabble.com/Rendering-of-disused-railway-stations-tp5745223p5745232.html
Sent from the Great Britain mailing list archive at Nabble.com.



More information about the Talk-GB mailing list