[OSM-talk] Problem with nodes in osmeditor2

Andrew Findlay andrew at findlay.org
Tue Apr 11 15:19:16 BST 2006


On Tue, Apr 11, 2006 at 02:58:56PM +0100, Nick Whitelegg wrote:

> >That is exactly the process that I tried initially, but it results in
> >new nodes at each end of each segment. Even if I clamp the mouse in
> >position while clicking I seem to get two nodes in the same place.
> >This is easy to test - just make some 'joined up' segments and use the
> >move-node tool to shift one of the joins: one line goes with the node,
> >the other stays put.
> 
> >Given the red circle that appears when you click, I had expected a
> >'snap to nearest existing node inside circle' behaviour.
> 
> That could be the problem - the red circle is just there to highlight a 
> node. When selecting on it you have to click right on the node. This is to 
> avoid ambiguities which might arise if more than one node was within the 
> red circle. However, I'm happy to change this behaviour if it's seen as 
> counter-intuitive.

I think there is a bug to be fixed first. I have tried some more tests,
and found that I *can* link segments to nodes downloaded from OSM, but
*cannot* link them to nodes created locally (e.g. those made by the
segment tool itself). There is a fairly large tolerance in the mouse
position when this works, so it looks as if the 'snap' action is there.

Andrew
-- 
-----------------------------------------------------------------------
|                 From Andrew Findlay, Skills 1st Ltd                 |
| Consultant in large-scale systems, networks, and directory services |
|     http://www.skills-1st.co.uk/                +44 1628 782565     |
-----------------------------------------------------------------------




More information about the talk mailing list