[OSM-talk] server cannot find mod_tile

Kenneth Gonsalves lawgon at au-kbc.org
Fri Feb 27 11:38:00 GMT 2009


On Thursday 26 February 2009 21:02:37 you wrote:
> > I had run it previously - I now recall that after the error in make, I
> > ran make again and did not get any error. So I thought it was ok. This
> > time also, running make the second time did not give any error. The
> > mod_tile is from the svn head. I am on fedora10. I am able to generate
> > images and tiles using mapnik-python, so I guess everything else is in
> > place.
>
> It looks to me as if the mapnik python dependencies are working but
> the c headers have not been installed.  That it works at all looks
> like a problem with the make file dependencies (but I've noticed some
> oddness there before so I'm not surprised).  If it doesn't work
> immediately after the make clean then it didn't work :-)
>
> So - back a stage, how did you install mapnik? Source or an rpm?

it was from svn head. I went back and built it again. Then rebuilt mod_tile. 
Got no errors. Ran ./renderd - first got an error as it was looking fonts in 
/usr/local/lib64/mapnik/fonts. Found this hardcoded and changed it. Now both 
renderd and renderd.py give the same error:

Render fd(6) xml(Default), z(0), x(0), y(0)
./renderd: symbol lookup error: ./renderd: undefined symbol: 
_ZN6mapnik3Map15set_buffer_sizeEi

Hopefully if this is solved, it will work ;-)
-- 
regards
Kenneth Gonsalves
Associate
NRC-FOSS
http://nrcfosshelpline.in/web/





More information about the talk mailing list